社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 4298阅读
  • 7回复

[求助]为什么不能将“逻辑型”数据转换到“文本型”数据

楼层直达
级别: 托儿所
发帖
2
铜币
84
威望
0
E积分
0
技术积分
0

.版本 2

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕

提升进程权限 ()
窗口句柄 = 取窗口句柄 (, “elementclient”)
进程ID = 取窗口进程ID (窗口句柄)


.子程序 _按钮2_被单击

写整型内存 (进程ID, 4526357, 3465222762)
按钮2.可视 = 假
按钮7.可视 = 真

.子程序 _按钮3_被单击

写整型内存 (进程ID, 4323208, 3386426073)
按钮3.可视 = 假
按钮8.可视 = 真

.子程序 _按钮1_被单击

写整型内存 (进程ID, 4218547, 1099547353)
按钮1.可视 = 假
按钮6.可视 = 真

.子程序 _按钮4_被单击

写整型内存 (进程ID, 4219840, 1317602164)
按钮4.可视 = 假
按钮9.可视 = 真

.子程序 _按钮5_被单击

写整型内存 (进程ID, 4597448, 4169366133)
按钮5.可视 = 假
按钮10.可视 = 真

.子程序 防封
.局部变量 a, 整数型
.局部变量 b, 整数型
.局部变量 c, 整数型

a = 读整型内存 (进程ID, 十六到十 (“8FC55C”))
b = 读整型内存 (进程ID, a + 十六到十 (“20”))
c = 读整型内存 (进程ID, b + 十六到十 (“62C”))
写整型内存 (进程ID, c, 16)


.子程序 _按钮6_被单击

写整型内存 (进程ID, 4218547, 1099547097)
按钮6.可视 = 假
按钮1.可视 = 真

.子程序 _按钮7_被单击

写整型内存 (进程ID, 4526357, 3465218666)
按钮7.可视 = 假
按钮2.可视 = 真

.子程序 _按钮8_被单击

写整型内存 (进程ID, 4323208, 3386425561)
按钮8.可视 = 假
按钮3.可视 = 真

.子程序 _按钮9_被单击

写整型内存 (进程ID, 4219840, 1317602165)
按钮9.可视 = 假
按钮4.可视 = 真

.子程序 _按钮10_被单击

写整型内存 (进程ID, 4597448, 4169366132)
按钮10.可视 = 假
按钮5.可视 = 真

.子程序 __启动窗口_将被销毁


发帖
931
铜币
1944
威望
1
E积分
0
技术积分
0
只看该作者 沙发  发表于: 2007-10-30

飞扬里提供了一个【逻辑类】,有一个静态方法,叫【到文本】,你可以这样使用  逻辑类.到文本( 假)或者逻辑类.到文本( 真); 关于这一点,我有点不喜欢官方的做法,在c#里所有类型都提供一个ToString的函数,而且可以重写,搞不懂为什么官方还搞出一个逻辑类,建议你看看 支持库中 的【系统】库,最基本的东西都在这,还是要挂一个耳朵,官方的做法实在太让人不能接受哦。

发帖
931
铜币
1944
威望
1
E积分
0
技术积分
0
只看该作者 板凳  发表于: 2007-10-30
后来我看怎么楼主说的好像是老版本的易语言?怎么跑到飞扬专区发帖来了?
级别: 托儿所
发帖
3
铜币
45
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 2017-08-11
我跟楼主同求=-=
发帖
52
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 4楼 发表于: 2017-08-30
过来看看,,,
级别: 托儿所
发帖
3
铜币
53
威望
0
E积分
0
技术积分
0
只看该作者 5楼 发表于: 2017-10-13
强烈支持,楼主万岁!
打牌从来没赢过   zzzxr.com
程序一体麻将机   zzzxr.com
程序麻将机原理   zzzxr.com
程序麻将机价格   zzzxr.com
不会打牌怎么办   zzzxr.com
北京程序麻将机   zzzxr.com
安装麻将机程序   zzzxr.com
最新单人作分析   zzzxr.com
自动麻将桌多少钱   zzzxr.com
自动麻将机多少钱   zzzxr.com
纸牌隐形   zzzxr.com
这几天打牌天天输   zzzxr.com
怎么打牌老是输钱   zzzxr.com
姚记密码纸牌   zzzxr.com
为什么打牌总是输   zzzxr.com
为什么打牌天天输   zzzxr.com
为什么打牌老输钱   zzzxr.com
为啥打牌老是输钱   zzzxr.com
微信怎么玩法   zzzxr.com
万能麻将机控制器   zzzxr.com
玩有什么技巧   zzzxr.com
十代单人作   zzzxr.com
什么是程序麻将机   zzzxr.com
怎样才能赢钱   zzzxr.com
如何打牌才能赢钱   zzzxr.com
如何成为打牌高手   zzzxr.com
普通纸牌怎么认牌   zzzxr.com
普通牌感应器   zzzxr.com
普通牌分析仪   zzzxr.com
普通牌小九分析仪   zzzxr.com
普通牌分析仪   zzzxr.com
普通牌牛牛分析仪   zzzxr.com
普通牌斗牛分析仪   zzzxr.com
普通牌电脑分析仪   zzzxr.com
普通麻将机装程序   zzzxr.com
普通麻将机免安装   zzzxr.com
牌玩法与技巧   zzzxr.com
免安装麻将机万能   zzzxr.com
麻将桌遥控多少钱   zzzxr.com
麻将桌多少钱一台   zzzxr.com
麻将机万能遥控器   zzzxr.com
麻将机高科技产品   zzzxr.com
麻将机多少钱一台   zzzxr.com
麻将机程序智能卡   zzzxr.com
广东牌具娱乐产品   zzzxr.com
级别: 托儿所
发帖
4
铜币
54
威望
0
E积分
0
技术积分
0
只看该作者 6楼 发表于: 2017-10-16

国外uu,国产uu最新地址开放注册了,网站难找



iujlb.com
级别: 托儿所
发帖
3
铜币
53
威望
0
E积分
0
技术积分
0
只看该作者 7楼 发表于: 01-18
名爵国际 娱 乐 城 900868.com
六 合 彩9:28依然可以投注,特别号码48倍。百 家 乐 ,龙 虎 斗, 骰宝, 轮盘, 全国各地的时 时 彩 都可以投注。即时入款出款,大数目无忧,各方面都有安全保障!
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个