社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 7353阅读
  • 29回复

[已解答]一个易语言sql数据库ERP系统,其实功能很强大

楼层直达
发帖
137
铜币
405
威望
0
E积分
0
技术积分
0



源码暂时不放,涉及到太多商业性东东
下面代码加载了一个树型框


.版本 2
.支持库 iext
.子程序 _y员工组别管理_创建完毕
顶层项目父ID = “LRG”
取员工组数据列表 ()
操作权限ID = 2
.判断开始 (_启动窗口.验证用户权限 () > 0)
.默认
    按钮2.禁止 = 真
    按钮3.禁止 = 真
    按钮4.禁止 = 真
    按钮5.禁止 = 真
    按钮6.禁止 = 真
    按钮7.禁止 = 真
    按钮8.禁止 = 真
.判断结束

.子程序 取员工组数据列表, , , 加载员工组别结构
.局部变量 父组别ID, 文本型
.局部变量 组别ID, 文本型
.局部变量 组名, 文本型
清除数组 (组别ID文本数组)
清除数组 (父组别ID文本数组)
组别列表.清空 ()
待换组别列表.清空 ()
' 处理项层项目
i = 0
sql = “select typename,typeid,supperid from employeegroup where supperid='” + 顶层项目父ID + “'”
记录集1 = 主数据库.查询 (sql)
.判断开始 (记录集1 ≠ 0)
.默认
    信息框 (“加载员工组列表失败,请检查网络及数据库状态!”, 0, )
    主数据库.关闭记录集 (记录集1)
    返回 ()
.判断结束
计次 = 0
.判断循环首 (主数据库.尾记录后 (记录集1) = 假)
    i = i + 1
    父组别ID = 到文本 (主数据库.读 (记录集1, “supperid”))
    组别ID = 到文本 (主数据库.读 (记录集1, “typeid”))
    组名 = 到文本 (主数据库.读 (记录集1, “typename”))
    组别列表.加入项目 (-1, 组名, , , i, 真, 0)
    待换组别列表.加入项目 (-1, 组名, , , i, 真, 0)
    加入成员 (父组别ID文本数组, 父组别ID)
    加入成员 (组别ID文本数组, 组别ID)
    主数据库.到后一记录 (记录集1)
.判断循环尾 ()
主数据库.关闭记录集 (记录集1)
sql = “select distinct len(supperid) from employeegroup where supperid<>'” + 顶层项目父ID + “' order by len(supperid)”
记录集1 = 主数据库.查询 (sql)
.判断开始 (记录集1 ≠ 0)
.默认
    信息框 (“加载员工组列表失败,请检查网络及数据库状态!”, 0, )
    主数据库.关闭记录集 (记录集1)
    返回 ()
.判断结束
主数据库.到首记录 (记录集1)
.判断循环首 (主数据库.尾记录后 (记录集1) = 假)
    sql = “select typename,typeid,supperid from employeegroup where supperid<>'” + 顶层项目父ID + “' and len(supperid)=” + 到文本 (主数据库.读 (记录集1, 1)) + “ order by typeid asc”
    记录集2 = 主数据库.查询 (sql)
    .判断开始 (记录集2 ≠ 0)
    .默认
        信息框 (“加载员工组列表失败,请检查网络及数据库状态!”, 0, )
        主数据库.关闭记录集 (记录集2)
        返回 ()
    .判断结束
    主数据库.到首记录 (记录集2)
    .判断循环首 (主数据库.尾记录后 (记录集2) = 假)
        父组别ID = 到文本 (主数据库.读 (记录集2, “supperid”))
        组别ID = 到文本 (主数据库.读 (记录集2, “typeid”))
        组名 = 到文本 (主数据库.读 (记录集2, “typename”))
        .计次循环首 (组别列表.取项目数 (), 计次)
            .判断开始 (组别ID文本数组 [组别列表.取项目数值 (计次 - 1)] = 父组别ID)
                i = i + 1
                组别列表.加入项目 (计次 - 1, 组名, , , i, 真, 0)
                待换组别列表.加入项目 (计次 - 1, 组名, , , i, 真, 0)
                加入成员 (父组别ID文本数组, 父组别ID)
                加入成员 (组别ID文本数组, 组别ID)
                跳出循环 ()
            .默认
            .判断结束
        .计次循环尾 ()
        主数据库.到后一记录 (记录集2)
    .判断循环尾 ()
    主数据库.关闭记录集 (记录集2)
    主数据库.到后一记录 (记录集1)
.判断循环尾 ()
主数据库.关闭记录集 (记录集1)
.计次循环首 (5, 计次)
    组别列表.扩展 (计次 - 1)
    待换组别列表.扩展 (计次 - 1)
.计次循环尾 ()
' 搜索子项目


发帖
2392
铜币
9426
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 2012-08-18
光加载个树型框就用了近百行程序代码,可想而知搞一个ERP系统,代码量将有多大?
发帖
128
铜币
313
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 2012-08-22
不大,我搞了几个月,写了一部分。都不想搞了
发帖
2392
铜币
9426
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 2012-08-22
谁搞都一样,几个月的时间是写不出一个完整的ERP系统的。如果易语言具有树型框填充函数,具有表格和超级列表框绑定数据库功能,具有编辑框、组合框等控件的数据源功能,那么只要十天半月就能完成一个完整的大型项目,那才能体现出易语言的“易”呐。
发帖
137
铜币
405
威望
0
E积分
0
技术积分
0
只看该作者 4楼 发表于: 2012-08-22
我现在的任务是1个半月,完成一个精铸厂的数据系统。到现在20天已完成了员工、客户、物料、产品、工艺、下单这几个板块的内容,后面只要把仓库、模具、外发系统,计工系统完成,基本上就可以了,后期再搞搞数据综合分析一类
发帖
286
铜币
87
威望
0
E积分
0
技术积分
0
只看该作者 5楼 发表于: 2012-09-27
    
wgm
发帖
129
铜币
207
威望
0
E积分
0
技术积分
0
只看该作者 6楼 发表于: 2012-09-27
发帖
207
铜币
534
威望
0
E积分
0
技术积分
0
只看该作者 7楼 发表于: 2012-10-17
期待公布部分源码
级别: 商业用户
发帖
210
铜币
247
威望
0
E积分
0
技术积分
0
只看该作者 8楼 发表于: 2013-01-10
       期待源码
发帖
233
铜币
476
威望
0
E积分
0
技术积分
0
只看该作者 9楼 发表于: 2013-01-11
      
快速回复

限60 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
认证码:
上一个 下一个