社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 1798阅读
  • 3回复

[求助]分割文本或字节集问题,我表达不清楚,请大牛进来详看

楼层直达
发帖
251
铜币
736
威望
0
E积分
0
技术积分
0
比如我加个变量.哈哈(文本型)
哈哈=abcdefghijklmn
到字节集(哈哈)
abcdefghijklmn到字节集就是{97,98,99,100,101,102,103,104,105,106,107,108,109,110}


有什么办法可以让它得出数据是{97,0,98,0,99,0,100,0,101,0,102,0,103,0,104,0,105,0,106,0,107,0,108,0,109,0,110,0}
就是每个字节集之后都加一个数据0


请大牛帮助!谢谢了!
发帖
221
铜币
161
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 2012-08-21
字节集插入字节的命令是什么?怎么找不到,
如果有这种命令,可以用循环
发帖
622
铜币
484
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 2012-08-21
.版本 2
.支持库 spec

.子程序 __启动窗口_创建完毕
.局部变量 哈哈, 文本型
.局部变量 temp, 字节集
.局部变量 结果, 字节集
.局部变量 计次, 整数型

哈哈 = “abcdefghijklmn”
temp = 到字节集 (哈哈)
结果 = 取空白字节集 (取字节集长度 (temp) × 2)
.计次循环首 (取字节集长度 (temp), 计次)
    结果 [计次 × 2 - 1] = temp [计次]
.计次循环尾 ()
调试输出 (结果)
本帖最近评分记录: 1 条评分 铜币 +2
fat951129 铜币 +2 2012-08-21 非常感谢,OK了
发帖
251
铜币
736
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 2012-08-21
非常感谢,OK了
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个