社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 86阅读
  • 5回复

取随机数 (, )  ' 产生不了大于32768的整数

楼层直达
级别: 商业用户
发帖
434
铜币
944
威望
0
E积分
0
技术积分
0
.版本 2


.程序集 窗口程序集_启动窗口


.子程序 __启动窗口_创建完毕


.子程序 _按钮1_被单击
.局部变量 zs, 整数型
.局部变量 i, 整数型


置随机数种子 ()
.计次循环首 (10000000, i)
    zs = 取随机数 (, )  ' 产生不了大于32768的整数
    .如果真 (zs > 32768)
        输出调试文本 (zs)


    .如果真结束


.计次循环尾 ()
输出调试文本 (“jieshu”)


取随机数产生不了大于32768的整数.e (3 K) 下载次数:1
级别: 幼儿园
发帖
32
铜币
30
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 06-22
zs = 取随机数 (, )  
+++++++++++++
你没有给出范围啊,,,,
级别: 商业用户
发帖
434
铜币
944
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 06-23
参数<2>的名称为“欲取随机数的最大值”,类型为“整数型(int)”,可以被省略。参数必须大于或等于零。本参数如果被省略,默认为无限。
级别: 商业用户
发帖
434
铜币
944
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 06-23
已解决

合并整数 (取随机数 (, ), 取随机数 (, ))
级别: 托儿所
发帖
1
铜币
51
威望
0
E积分
0
技术积分
0
只看该作者 4楼 发表于: 06-23
发帖
56
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 5楼 发表于: 昨天 08:31
置随机数种子 ()
.计次循环首 (10000000, i)
    zs = 取随机数 (, )  ' 产生不了大于32768的整数
    .如果真 (zs > 32768)
        输出调试文本 (zs)
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个