社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 200阅读
  • 4回复

_编辑框1_内容被改变  编辑框1.内容 = “”  程序直接退出

楼层直达
级别: 托儿所
发帖
1
铜币
52
威望
0
E积分
0
技术积分
0
在  _编辑框1_内容被改变  子程序
编辑框1.内容 = “”
在编辑框输入内容,程序直接退出
易语言版本5.71加密狗版
级别: 托儿所
发帖
2
铜币
52
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 10-23
三域商品支持抗单 三域商品支持抗单 三域商品支持抗单  可持仓过夜  招商总监电话13129739899(同微信)
si
发帖
6643
铜币
12816
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 10-27
Re:_编辑框1_内容被改变  编辑框1.内容 = “”  程序直接退 ..
编辑框1.内容 = “”    这句代码会调用  _编辑框1_内容被改变 事件,
你写的代码就成死循环了,无限递归调用,调用栈满就崩溃了。
  1. .版本 2
  2. .子程序 _编辑框1_内容被改变
  3. .如果真 (编辑框1.内容 ≠ “”)
  4.     编辑框1.内容 = “”
  5. .如果真结束

这样写就可以了,如果内容已经是空的就不改变内容,就不会继续了
级别: 幼儿园
发帖
20
铜币
17
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 10-31
Re:_编辑框1_内容被改变  编辑框1.内容 = “”  程序直接退 ..
en   有错误首先你要 debug
级别: 托儿所
发帖
2
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 4楼 发表于: 10-31
Re:_编辑框1_内容被改变  编辑框1.内容 = “”  程序直接退 ..
333
快速回复

限60 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
认证码:
上一个 下一个