社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 159阅读
  • 10回复

Re:怎么让列表框与编辑框内容同步

楼层直达
发帖
53
铜币
73
威望
0
E积分
0
技术积分
0
怎么让列表框与编辑框内容同步。

[ 此帖被虎妹在2017-11-07 11:46重新编辑 ]
发帖
53
铜币
73
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 11-01
级别: 幼儿园
发帖
27
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 11-01
.版本 2
.支持库 iext

.子程序 超级列表框关键列置色, , 公开
.参数 参数_窗口, 窗口
.参数 参数_超级列表框, 超级列表框, , 对象
.参数 参数_关键列, 整数型, , 索引
.参数 参数_关键字, 文本型
.参数 参数_文本颜色, 整数型
.参数 参数_背景颜色, 整数型
.局部变量 计次, 整数型
.局部变量 临时文本, 文本型

计次 = 0
.计次循环首 (参数_超级列表框.取表项数 (), 计次)
    临时文本 = 参数_超级列表框.取标题 (计次 - 1, 参数_关键列)
    .如果真 (临时文本 ≠ 子文本替换 (临时文本, 参数_关键字, “*”, , , 真))
        超级列表框_设置行色 (参数_窗口, 参数_超级列表框, 计次 - 1, 参数_文本颜色, 参数_背景颜色)
        计次 = 计次 + 1
    .如果真结束

.计次循环尾 ()
参数_超级列表框.重画 ()
发帖
53
铜币
73
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 11-03
级别: 幼儿园
发帖
26
铜币
4
威望
0
E积分
0
技术积分
0
只看该作者 4楼 发表于: 11-04
16位中文字符密码
ziv
发帖
75
铜币
4580
威望
0
E积分
1
技术积分
0
只看该作者 5楼 发表于: 11-06
                                                                              .
级别: 幼儿园
发帖
49
铜币
1287
威望
0
E积分
0
技术积分
0
只看该作者 6楼 发表于: 11-08
什么鬼
级别: 幼儿园
发帖
49
铜币
1287
威望
0
E积分
0
技术积分
0
只看该作者 7楼 发表于: 11-08
西方财富酒店南纸
级别: 幼儿园
发帖
49
铜币
1287
威望
0
E积分
0
技术积分
0
只看该作者 8楼 发表于: 11-08
66666666666666
Re-怎么让列表框与编辑框内容同步
级别: 托儿所
发帖
8
铜币
289
威望
0
E积分
0
技术积分
0
只看该作者 9楼 发表于: 11-09
1.编辑框内容与列表同步:当点击列表项目时,编辑框.内容=列表框.取标题(列表框.现行选中项)

2.列表与编辑框内容同步:
                                
   a. 编辑框内容被改变下
                 如果列表现行选中项不等于1时,列表框.置标题(列表框.现行选中项,编辑框.内容)
    b.编辑框失去焦点下
                 如果列表现行选中项不等于1时,列表框.置标题(列表框.现行选中项,编辑框.内容)

                  
快速回复

限60 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
认证码:
上一个 下一个