社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 121阅读
  • 2回复

[练习]新人报道,来麻烦大家了数组成员引用下标超出定义范围

楼层直达
级别: 托儿所
发帖
1
铜币
50
威望
0
E积分
0
技术积分
0

.版本 2
.支持库 shellEx
.支持库 spec
.程序集 窗口程序集_启动窗口
.程序集变量 A, 整数型
.程序集变量 屏幕底图, 字节集
.程序集变量 按住, 逻辑型
.程序集变量 当前位置, 整数型, , "0"
.子程序 __启动窗口_创建完毕
A = 注册热键 (_启动窗口.取窗口句柄 (), 标签1.取窗口句柄 (), #Alt键状态, #A键)

.子程序 _标签1_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
.如果真 (参数一 = A)
    _启动窗口.位置 = 2
    延迟 (50)  ' 关键
    屏幕底图 = 快照 (, , )
    延迟 (50)
    _启动窗口.位置 = 3
    _启动窗口.底图 = 屏幕底图
    区域画板.底图 = _启动窗口.底图
    ' _启动窗口.移动 (0 , 0, 取屏幕宽度 (), 取屏幕高度())
    区域画板.移动 (0, 0, 取屏幕宽度 (), 取屏幕高度 ())
    标签1.可视 = 假
.如果真结束

.子程序 __启动窗口_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
按住 = 真
当前位置 [1] = 横向位置
当前位置 [2] = 纵向位置
外形框1.移动 (当前位置 [1], 当前位置 [2], 100, 100)
外形框1.可视 = 真
外形框2.左边 = 1
外形框2.顶边 = 1
区域画板.移动 (-当前位置 [1], -当前位置 [2], , )  ' 关键语句


还没写完  麻烦大神帮忙看看 哪里出错了 谢谢
级别: 商业用户
发帖
75
铜币
50
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 01-23
这根本不是你写的
如果是你写的 区区一个数组下标错误竟然不知道 那就有点可笑了
发帖
816
铜币
6118
威望
0
E积分
1
技术积分
0
只看该作者 板凳  发表于: 02-02
    
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个