社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 123阅读
  • 1回复

[练习]列表框批量删除包含指定字符项

楼层直达
级别: 幼儿园
发帖
32
铜币
524
威望
0
E积分
0
技术积分
0
删除列表框单个或多个包含指定字符的项

.版本 2

.程序集 窗口程序集1

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 要删除文本, 文本型

要删除文本 = 编辑框1.内容
.计次循环首 (列表框1.取项目数 (), i)
    .判断循环首 (寻找文本 (列表框1.取项目文本 (i - 1), 要删除文本, , 真) > 0)
        列表框1.删除项目 (i - 1)
    .判断循环尾 ()
.计次循环尾 ()

.子程序 _按钮2_被单击
.局部变量 i, 整数型
.局部变量 要删除文本1, 文本型
.局部变量 要删除文本2, 文本型

要删除文本1 = 编辑框2.内容
要删除文本2 = 编辑框3.内容
.计次循环首 (列表框1.取项目数 (), i)
    .判断循环首 (寻找文本 (列表框1.取项目文本 (i - 1), 要删除文本1, , 真) > 0 或 寻找文本 (列表框1.取项目文本 (i - 1), 要删除文本2, , 真) > 0)
        列表框1.删除项目 (i - 1)
    .判断循环尾 ()
.计次循环尾 ()
' 有个问题!要删除的文本不能为空,不然会清空列表框!!!
测试.e (5 K) 下载次数:2
级别: 托儿所
发帖
1
铜币
51
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 01-29
网上玩电子游艺就在[size=15pt]澳门新葡京娱乐场:6777234[size=15pt].com
网上玩可不可靠,关键是选择网站平台平台微信号:cfucfu888 ,大公司的大网站就值得信赖些,估且不说它是否合法,但会员多有信誉的网站又经过备案的,就可以放心。关键是安全有保障!
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个