社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 389阅读
  • 8回复

[解决]热敏小票打印机之ESC\POS指令集方式打印技术

楼层直达
发帖
311
铜币
130
威望
0
E积分
0
技术积分
0
冷门干货:支持串口、并口、USB、网口硬件通讯打印编程,直接硬件机器指令。
咨询官方技术无果,找了几十个资料,实验了5 6卷打印纸,花了一个星期时间终于有了眉目,基本搞定,后期再深度优化编译Dll动态链接库和调用模块开放共享,有相关需要和技术交流请联系QQ657717948 或添加易语言商业软件交流群:26660804


部分代码程序集



本帖最近评分记录: 3 条评分 铜币 +3
shituo 铜币 +1 02-15 你的dll收费的吧
mmmww3 铜币 +1 02-02 优秀文章,支持!n神马都是浮云
szxiao 铜币 +1 01-31 优秀文章,支持!n神马都是浮云
级别: 商业用户
发帖
1000
铜币
32
威望
0
E积分
14
技术积分
5
只看该作者 沙发  发表于: 01-31
优秀文章,支持!n神马都是浮云
级别: 商业用户
发帖
552
铜币
1095
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 01-31
哈哈,才看到,esc/pos(爱普生的标准)的打印指令集几年前就写了,这里直接给大家贴一份:
(打印机路径从HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses\{28d78fad-5a12-11d1-ae5b-0000f803a8c2}里面的子项取,COM、USB、LPT等类型的打印机都通用(前提是支持esc/pos的打印指令集标准),直接复制就能用。)
.版本 2

.子程序 打开打印机, 整数型, 公开, 0失败
.参数 打印机路径, 文本型
.局部变量 handle

handle = 打开文件 (打印机路径, , )
.如果真 (handle ≠ 0)
    打印_初始化 (handle)
    打印_设置字体对齐 (handle, 0)
    写出数据 (handle, 到字节集 (#换行符))
.如果真结束
返回 (handle)

.子程序 打印_初始化
.参数 handle, 整数型, , 0左,1中,2右

写出数据 (handle, { 27, 64 })  ' 初始化打印 ESC @

.子程序 打印一行, 逻辑型, 公开
.参数 打印句柄, 整数型
.参数 文本, 文本型

返回 (写出数据 (打印句柄, 文本 + #换行符))

.子程序 关闭打印, , 公开
.参数 打印句柄, 整数型

写出数据 (打印句柄, 到字节集 (#换行符 + #换行符 + #换行符))
' 写出数据 (打印句柄, { 28, 46 })  ' 取消中文
关闭文件 (打印句柄)

.子程序 打印_设置字体对齐, , 公开
.参数 handle, 整数型
.参数 对齐, , , 0左,1中,2右

' ESC a n
.判断开始 (对齐 = 0)
    写出数据 (handle, { 27, 97, 48 })  ' 居中
.判断 (对齐 = 1)
    写出数据 (handle, { 27, 97, 49 })  ' 居中
.判断 (对齐 = 2)
    写出数据 (handle, { 27, 97, 50 })  ' 居中
.默认

.判断结束



.子程序 打印_设置字体风格, , 公开
.参数 handle, 整数型
.参数 style, , , 常量#打印风格_

' ESC ! n
' FS ! n
写出数据 (handle, { 27, 33 } + 到字节集 (style))  ' 设置英文ESC 27
写出数据 (handle, { 28, 33 } + 到字节集 (style))  ' 设置中文FS  28


级别: 幼儿园
发帖
37
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 02-02
我要加群,我想学习
发帖
816
铜币
6118
威望
0
E积分
1
技术积分
0
只看该作者 4楼 发表于: 02-02
优秀文章,支持!n神马都是浮云
发帖
311
铜币
130
威望
0
E积分
0
技术积分
0
只看该作者 5楼 发表于: 02-12
钱箱控制及金额显示屏功能


发帖
311
铜币
130
威望
0
E积分
0
技术积分
0
只看该作者 6楼 发表于: 02-12
回 楼主(657717948) 的帖子
钱箱及前显功能见5楼帖子
级别: 商业用户
发帖
36
铜币
5447
威望
0
E积分
0
技术积分
0
只看该作者 7楼 发表于: 02-13
确实不错!
发帖
1381
铜币
776
威望
0
E积分
2
技术积分
5
只看该作者 8楼 发表于: 02-15
你的dll收费的吧
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个