社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 57阅读
  • 2回复

[问题]请教大神们一个问题

楼层直达
级别: 托儿所
发帖
2
铜币
53
威望
0
E积分
0
技术积分
0
错误(10044): 不能将“整数型”数据转换到“文本型”数据。

代码如下:
.程序集 窗口程序集_启动窗口
.子程序 _按钮1_被单击
.局部变量 静态变量, 整数型, 静态
.局部变量 非静态变量, 整数型
编辑框1.内容 = 编辑框1.内容 + “当前静态变量的值为:” + 到文本 (静态变量) + #换行符
编辑框1.内容 = 编辑框1.内容 + “当前非静态变量的值为:” + 到文本 (静态变量) + #换行符
静态变量 = “静态变量” + 1
非静态变量 = “非静态变量” + 1

我按书上操作的,这是哪里出的错?
级别: 托儿所
发帖
3
铜币
45
威望
0
E积分
0
技术积分
0
只看该作者 沙发  发表于: 04-16
静态变量 = “静态变量” + 1    
非静态变量 = “非静态变量” + 1
去掉引号
级别: 托儿所
发帖
2
铜币
53
威望
0
E积分
0
技术积分
0
只看该作者 板凳  发表于: 04-17
回 1楼(az75) 的帖子
谢谢,非常感谢。
快速回复

限60 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
认证码:
上一个 下一个