社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 4343阅读
  • 4回复

[分享]计算指定日期是当年的第几天(附源码)

楼层直达
级别: 贵宾
发帖
11043
铜币
4493
威望
0
E积分
7
技术积分
0
前两天在QQ群里,飘渺给我等菜鸟出一问题,求某一天是这一年的第几天。我想,这容易啊,就用了支持库里的几个命令,很快搞定。人家说啦,要是让你用支持库命令,还有什么意思?自己算。
呵呵,难为我。
咱就再想办法。结果,今天搞了这么个例程出来。不仅计算简单,而且准确。
这里谢谢飘渺的指导!
TEfNxeOt.e (4 K) 下载次数:239
你可以菜,但你不可以懒。你不可以把你的菜当作你无耻的资本,把别人无休止地变成为你无偿写代码的工具。做人要正直,别轻易下跪。今天你可以为一句代码下跪,你明天就会因为没得到代码而骂娘!学习靠自己,努力吧!
发帖
843
铜币
2245
威望
0
E积分
24
技术积分
0
只看该作者 沙发  发表于: 2006-01-03
计算指定日期是当年的第几天
级别: 贵宾
发帖
11043
铜币
4493
威望
0
E积分
7
技术积分
0
只看该作者 板凳  发表于: 2006-01-03
[quote]以下是引用[I]xokxiao[/I]在2006-1-3 12:52:00的发言:[BR]计算指定日期是当年的第几天[/QUOTE]

是啊,计算指定日期是其所在年份的第几天。如果用易支持库命令,一个指令就行。这里是为了熟悉命令,练习算法,用了别的办法。
你可以菜,但你不可以懒。你不可以把你的菜当作你无耻的资本,把别人无休止地变成为你无偿写代码的工具。做人要正直,别轻易下跪。今天你可以为一句代码下跪,你明天就会因为没得到代码而骂娘!学习靠自己,努力吧!
级别: 幼儿园
发帖
20
铜币
119
威望
0
E积分
0
技术积分
0
只看该作者 地板  发表于: 2009-07-30

.版本 2


.局部变量 年, 整数型
.局部变量 月, 整数型
.局部变量 日, 整数型
.局部变量 天, 整数型


年 = 取年份 (日期框1.今天)
月 = 取月份 (日期框1.今天)
日 = 取日 (日期框1.今天)
.判断开始 (月 = 1)
    天 = 0
.判断 (月 = 2)
    天 = 31
.判断 (月 = 3)
    天 = 59
.判断 (月 = 4)
    天 = 90
.判断 (月 = 5)
    天 = 120
.判断 (月 = 6)
    天 = 151
.判断 (月 = 7)
    天 = 181
.判断 (月 = 8)
    天 = 212
.判断 (月 = 9)
    天 = 243
.判断 (月 = 10)
    天 = 273
.判断 (月 = 11)
    天 = 304
.判断 (月 = 12)
    天 = 334
.默认


.判断结束
天 = 天 + 日
.如果真 (年 % 4 = 0)
    天 = 天 + 1
.如果真结束


标签1.标题 = 到文本 (年) + “年” + 到文本 (月) + “月” + 到文本 (日) + “日是” + 到文本 (年) + “年的第” + 到文本 (天) + “天。”


 

发帖
4645
铜币
357
威望
0
E积分
0
技术积分
0
只看该作者 4楼 发表于: 2009-07-30

4楼的你都做到这份上了,我只好再改一改啦


 


定义一个变量 天数 整数型 数组[12]


 


天数={0,31,59,90....}'后面不写了


然后直接输出就行了:


 


总天数=天数[月份]+天‘这个天是当月有多少天,这里还要判断是否是闰年,我就不写代码了,有两种方法,本来想写个例程,但没时间,说一下算了:


第一种:直接取那一年的第二个是多少天,如果是29天,那么就是闰年,否则不是


第二种:先判断年能否被4整除,再判断是否能被400整除且不能被100整除的年才叫闰年,如2000是闰年,但1900不是闰年


 


 


PS:我那次说了这个数组用法,没人学会吗?还是你们不屑于用呢?唉,不想多说了。。。。


 


[此贴子已经被作者于2009-7-30 17:33:56编辑过]
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个