社区应用 社区服务 会员列表 统计排行 帮助 银行
  • 13753阅读
  • 82回复

[原创]读取MYSQL库中所有的表名及其相应的字段列表

楼层直达
级别: 托儿所
发帖
5
铜币
9
威望
0
E积分
0
技术积分
0
只看该作者 40楼 发表于: 2013-08-24
发现本例子中有一处错误:计次循环首的记数变量是从1开始的,而数据库中字段的序号是从0开始的。所以下面这一部分应该是这样的:

.版本 2
.支持库 mysql

.子程序 _信息列表框_列表项被选择
.局部变量 SQL语句, 文本型
.局部变量 字段总数, 整数型
.局部变量 字段名, 文本型
.局部变量 计数, 整数型

字段信息列表框.清空 ()
SQL语句 = “select * from ” + 信息列表框.取项目文本 (信息列表框.现行选中项)
执行SQL语句 (MySql句柄, SQL语句)
记录集句柄 = 取记录集 (MySql句柄)
字段总数 = 取字段总数 (记录集句柄)
当前表字段标签.标题 = “当前表:” + 信息列表框.取项目文本 (信息列表框.现行选中项) + “有:” + 到文本 (字段总数) + “个字段”
.计次循环首 (字段总数, 计数)
    序号到字段名 (记录集句柄, 计数 - 1, 字段名)  ' 计次循环首的记数变量是从1开始的,而数据库中的序号是从0开始的。
    字段信息列表框.加入项目 (字段名 + 取空白文本 (3), )
    到下一行 (记录集句柄)
    处理事件 ()
.计次循环尾 ()
释放记录集 (记录集句柄)
级别: 幼儿园
发帖
20
铜币
53
威望
0
E积分
0
技术积分
0
只看该作者 41楼 发表于: 2014-02-05
v好好顶板
v好好顶板

级别: 幼儿园
发帖
18
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 42楼 发表于: 2014-02-14
顶下起,希望对我有帮助!
级别: 幼儿园
发帖
37
铜币
3
威望
0
E积分
0
技术积分
0
只看该作者 43楼 发表于: 2014-02-24
看看,学习下先·············
发帖
69
铜币
0
威望
0
E积分
0
技术积分
0
只看该作者 44楼 发表于: 2014-02-24
谢谢楼主分享共和国
发帖
109
铜币
-2
威望
0
E积分
0
技术积分
0
只看该作者 45楼 发表于: 2014-03-07
顶一下 继续发扬
发帖
109
铜币
-2
威望
0
E积分
0
技术积分
0
只看该作者 46楼 发表于: 2014-03-07
就差这个不会了,,,,,
级别: 禁止发言
发帖
860
铜币
526
威望
0
E积分
0
技术积分
0
只看该作者 47楼 发表于: 2014-04-01
用户被禁言,该主题自动屏蔽!
级别: 幼儿园
发帖
7
铜币
1
威望
0
E积分
0
技术积分
0
只看该作者 48楼 发表于: 2014-05-14
顶两下! 顶两下! 顶两下!
发帖
115
铜币
8
威望
0
E积分
0
技术积分
0
只看该作者 49楼 发表于: 2014-05-22
          
快速回复

限60 字节
批量上传需要先选择文件,再选择上传
 
认证码:
上一个 下一个